Results 1 to 9 of 9

Thread: Classic mining guide lag

  1. #1

    Default Classic mining guide lag

    i was leveling my mining up for classic wow and selected the guide to do the farm round when i get attacked by a mob and kill it or leave combat i have a masive lag spike
    so went on a search and disabled dugi to see if it was the addon that coused it and sure thing disabled dugi and the lag spikes where gone so for now this is a bug report to look into it and hope to fix it

    if you need more info please ask me what i can do to make your life easyer dugi

  2. #2
    Administrator Undead Male Warrior
    Dugi's Avatar
    Join Date
    Nov 2008
    Posts
    6,856

    Default

    I'm testing this and I can't seem to replicate the issue, can you confirm it with only Dugi enabled.

  3. #3

    Default

    ok so i tested it with no addons on exept dugi and i still have it but its not as long as it was with all my addons on
    also tested it with elvui on and dugi and the lag spikes became more heavy and longer then when i only had dugi on
    but again the lag spike was there with only dugi but not as long as it was befor

  4. #4
    Senior Member NightElf Female Warlock

    Join Date
    Jan 2011
    Posts
    541

    Default

    I agree with Dugi, I tested this and I can't seem to replicate this issue.
    Perhaps update to the latest Dugi Guides version (8.691) if you haven't already updated yet.

  5. #5

    Default

    i run the updater once a day so i bet i have it already

  6. #6
    Administrator Undead Male Warrior
    Dugi's Avatar
    Join Date
    Nov 2008
    Posts
    6,856

    Default

    which particular guide you're using, can you post screenshot, it might provide some clues

  7. #7

    Default

    Professions->Classic Leveling->Mining (1-300) i had it from copper mining in darkshore right away

  8. #8
    Senior Member NightElf Female Warlock

    Join Date
    Jan 2011
    Posts
    541

    Default

    I still can't replicate this.

    While in Darkshore, do you have the buff 'Time Travelling' wowhead.com\spell=290245?
    Assuming that the character is level 120.

    However, Virtual Memory can be at fault here, it's a long shot and after all we are stabbing in the dark here.
    I still show my face in MSFN forums from time to time as I still to this day have my subscription on auto renewal. Windows 10 is very buggy with determining the best Virtual Memory.

    Here's proof, my system has 32gb ram, Windows 10 allocated 4984mb, at that point I was getting memory leakage when ever my virtual memory hit or was above 90%. Assuming you're running Windows 10 that is, even if you are not, it's best to override the automatic settings anyway, especially if you're running over 8gb ram.

    Search for: System, it will be the one with Control Panel underneath it.
    Click on "Advanced system settings"
    In the Advanced tab click on Settings under Performance.
    Click on the Advanced tab.
    While here, ensure "Programs" is selected.
    Click on "Change..." button.

    uncheck Automatically manage paging file size for all drives.

    Note: If you have a SSD or SSHD you do not want to move the paging file to a mechanical drive, the performance on a SSD is a lot faster than a mechanical drive.

    Select a drive and select no paging file, select Set button. Do this for ALL drives.

    Once all drives had paging file deleted, click on C: if that's your System drive (with Windows installed on it, even if it is a SSD.)
    Select Custom size

    To resolve this issue, find your total "physical ram", for me it is 32 (1024 x 32) = 32768
    In the Initial size (MB) mine will be 32768

    To work out the Maximum size (MB), the maximum size always needs to be 1.5 times the physical (1024 x 32 x 1.5) = 49152

    Click on Set button and reboot the system.

    For 16gb ram it will be (1024 x 16 x 1.5) = 24576
    For 8gb ram it will be (1024 x 8 x 1.5) = 12288
    For 4gb ram it will be (1024 x 4 x 1.5) = 6144

    To help determine the memory usage while gaming or using memory intensive applications like adobe photoshop or sony vegas etc open up Task Manager (CTRL + Shift + ESC)
    Click on the Performance tab.
    in the bottom left, click on Open Resource Monitor link.
    Resource Monitor should appear, click on the memory tab, look at physical memory chart on the bottom.

    If there is less than 50% available then start trimming down what's running in the background, including services that you don't use.
    For this sort of thing videos like https://www.youtube.com/watch?v=QR1kmd9kYVY will help trim the unwanted services privacy & apps etc, after all these are optional, and always remember to create a restore point before making changes like those.
    Last edited by Caluril; 02-11-2019 at 05:01 AM.

  9. #9
    Administrator Undead Male Warrior
    Dugi's Avatar
    Join Date
    Nov 2008
    Posts
    6,856

    Default

    Some people have fixed similar problems in the past by clearing all their macros,

    try deleting all your macros, (back up the ones you want to keep to a txt file) and try again with only Dugi enabled.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •