Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 30

Thread: Bug - Guide lags game

  1. #1

    Default Bug - Guide lags game

    For some odd reason the Dugi guide viewer slightly lags the system after killing a mob. Just as the mob dies the game freezes for a fraction of a second.

    To get to this conclusion I did as follows:

    1. I tuned off all my addons and checked to see if this made a difference which it did - WoW worked perfectly without any lagging.
    2. Turned on Dugi guide and TomTom whilst leaving all my other addons off and found the game lagged again just after killing a mob.
    3. Turned off TomTom and left Dugi Guide on and lag after mob death continued.
    4. Turned off TomTom and Dugi Guide and then turned all my other addons I use back on and WoW functioned correctly after mob death.

    I am, before anyone asks, using the latest version of Dugi guide as of todays date.

    This lag problem also happens during PVP, so I am currently turning DUgi Guide off during battlegrounds as it is very annoying lol

    I hope the above explanation is understandable.

  2. #2

    Default

    Hi Wolf, I don't think this is an issue with Dugi's guide; more of a general problem with addons and memory usage.

    I have exactly the same issue however the problem is only impacting the game when I have Carbonite running and I went through exactly the same series of tests only replacing Carbonite for your Dugi's guide.

    It is annoying and I have disabled Carbonite but Dugi's guide works fine with no lag. I would try re installing all of your add ons see if that makes a difference, try dugi's guid first (with no other add on installed) and move on from there.

  3. #3

    Default

    I have the same thing
    If i turn off Dugi's guide and tomtom there is no lag.
    When i turn them on there is the lag again
    And btw it no latecy lag its peformance lag.
    Srry for the bad english :P
    And yes i have a up to date pc.

  4. #4

    Default

    Bacon,

    I removed all the addons (I just deleted the Interface folder) and ran WoW and found no lag when killing a mob. Installed Dugi Guide and no other addons and the game frozen for a fraction of a second after each mob kill. Uninstalled Dugi Guide and game returned to noraml.

    At the moment I'm just turning the Dugi Guide on and off as and when I need it. I definately do not have it turned on during BGs as it really does cause alot of lagging and freezing.

    Like you said Bacon, it probably isn't the Dugi Guide causing the problem, but it is very odd that the problem only occurs when using the Guide & TomTom and not with any other addon.

    Hopefully the next WoW bug fix will fix any memory leaks or whatever and will mean I can keep Dugi Guide turned on as I have in the past.

  5. #5

    Default

    I am having the same issue. I came to this conclusion by turning all addons off and turning them back on one at a time. The guide is the only one that caused the game to lag when killing a mob or when i looted said mob. This is not to much of a problem when grinding items but learned really early that when in an instance i can really freeze my game especially when there are multiple spawns killed at once. I reinstalled the latest downloads for all of dugi's addons and still have this issue.

  6. #6

    Default

    It seems to be a CPU bottleneck issue. When I OCd my CPU, the lag disappeared. Also, it was more severe in guides with lots of steps. When I switched to a tab with very few steps, the lag disappeared. I have screenshots somewhere, will post later.

  7. #7
    Administrator Undead Male Monk
    Dugi's Avatar
    Join Date
    Nov 2008
    Posts
    4,516

    Default

    We are looking into this but we can't seem to replicate the problem in any way.

    Can someone take a screenshot of their

    Video > Graphics settings
    Video > Advanced settings

    does this happen when you create a brand new level 1 character? with default settings.

    try renaming your WTF folder to WTF2 to reset all your settings for all characters, and test it again. You can rename WTF2 back to WTF to get it back afterwards.

  8. #8

    Default

    Found the screenies...

    Guide loaded, but viewer not showing, 30+ fps.


    Guide loaded + viewer showing big guide, ~10 fps.


    Guide loaded, viewer showing smaller guide, back to 30 fps.


    Memory footprint + my vid settings:



    I'll try the other suggestions when I have some more time.

    EDIT: those screenies are before I OC'd the CPU. I have an i7 640UM, default FSB speed is 133Mhz. At that speed the game lags with big guides loaded. OC'd to 166Mhz it doesn't lag as much (5-10% drop in FPS, as opposed to 75%), and when I use a tool that locks the multiplier, the lag is virtually gone (haven't tested thoroughly, but when you get 80+ fps, you don't really notice it when it drops to 70).
    Last edited by roxxor; 10-28-2010 at 08:39 PM.

  9. #9
    Administrator Undead Male Monk
    Dugi's Avatar
    Join Date
    Nov 2008
    Posts
    4,516

    Default

    Nevermind I think we have found the problem with the recent achievement detection.

  10. #10
    Administrator Undead Male Monk
    Dugi's Avatar
    Join Date
    Nov 2008
    Posts
    4,516

    Default

    try the latest update v4.33 it think we have fixed the issue.

    http://www.ultimatewowguide.com/addo...werZ_v4.33.zip

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •